Условие: Тип 8 № 7667

Сколько слов длины 5, начинающихся с гласной буквы, можно составить из букв Е, Г, Э? Каждая буква может входить в слово несколько раз.

Слова не обязательно должны быть взяты из русского языка.

Вариант 1: используем для перебора метод product из библиотеки itertools

Вариант 1: используем для перебора метод product из библиотеки itertools

Комментарии к первому варианту решения задачи:

  1. импортируем в проект встроенную библиотеку itertools
  2. создаем строку для согласных букв "Г"
  3. создаем строку для гласных букв "ЕЭ"
  4. переменную count будем использовать как счетчик подходящих слов
  5. через метод product составляем всевозможные слова из алфавита "ЕГЭ"
  6. пробегаем кортежи temp из получившегося контейнера s
  7. если первая буква кортежа temp[0] лежит в строке гласных
  8. увеличиваем счетчик count на +1 значение
  9. после пробежки всего цикла for выводим кол-во слов на экран
# Код решения Вариант 1
import itertools
sogl = 'Г'
glas = 'ЕЭ'
count = 0
s = itertools.product('ЕГЭ', repeat=5)
for temp in s:
    if temp[0] in glas:
        count += 1
print(count)

Вариант 2: немного освежили код из первого варианта

Вариант 2: немного освежили код из первого варианта

# Код решения Вариант 2
import itertools
count = 0
s = itertools.product('ЕГЭ', repeat=5)
for temp in s:
    if temp[0] in 'ЕЭ':
        count += 1
print(count)

Вариант 3: переберем все слова используя цикл for и строку алфавита "ЕГЭ”

Вариант 3: переберем все слова используя цикл for и строку алфавита "ЕГЭ”

Комментарии к третьему варианту решения задачи: