Условие КЕГЭ: Тип 2 № 6843 (Уровень: Средний) (А. Богданов)

Разбор 2.PNG

Логическая функция F задаётся выражением (zw)∧ y ∧¬ x. На рисунке приведён частично заполненный фрагмент таблицы истинности функции F, содержащий неповторяющиеся строки. Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных x, y, z, w.

? ? ? ? F
0 1 0 1
0 1
0 1 1 0

В ответе напишите буквы x, y, z, w в том порядке, в котором идут соответствующие им столбцы. Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Untitled

Комментарии к решению задачи:

  1. print(f'x y z w F') - Выводим заголовок столбцов, используя форматированную строку, чтобы отобразить названия переменных.
  2. for x in range(2): - Ищем все возможные варианты переменной x.
  3. for y in range(2): - Ищем все возможные варианты переменной y.
  4. for z in range(2): - Ищем все возможные варианты переменной z.
  5. for w in range(2): - Ищем все возможные варианты переменной w.
  6. F = (z <= w) and y and (not x) - задаём логическую функцию переменной F
  7. print(x, y, z, w, F) - Выводим значения переменных x, y, z, w и F.
print('x y z w F')
for x in range(2):
    for y in range(2):
        for z in range(2):
            for w in range(2):
                F = (z <= w) and y and (not x)
                print(x, y, z, w, F)

В ходе выполнения программы получаем следующую таблицу: