Разбор 24.PNG

Тип 24 № 59848 с сайта Решу ЕГЭ

Текстовый файл состоит не более чем из 10**6 символов латинского алфавита. Необходимо найти самую длинную подстроку, которая может являться числом в 24 системе счисления. В ответ записать длину последовательности символов, которая может являться числом в 24 системе счисления.

Примечание: число не может начинаться с нуля!

Скачать файл: 24.txt

Untitled

Комментарии к коду решения:

  1. alphabet = sorted('0123456789QWERTYUIOPASDFGHJKLZXCVBNM') - Создаем отсортированный список символов 36-ого алфавита.
  2. bad = alphabet[24:] - Собираем список символов, начиная с 25-го элемента алфавита используя срез (список плохих символов).
  3. s = open('24.txt').readline() - Чтение первой строки из файла '24.txt' и сохранение в переменную s.
  4. for x in bad: - Цикл по всем символам в списке bad.
  5. s = s.replace(x, ' ') - Замена каждого символа x в строке s на пробел.
  6. print(max([len(x) for x in s.split() if x[0] != '0'])) - Вывод максимальной длины слова, начинающегося не с '0', в строке s.
alphabet = sorted('0123456789QWERTYUIOPASDFGHJKLZXCVBNM')
bad = alphabet[24:]
s = open('24.txt').readline()
for x in bad:
    s = s.replace(x, ' ')
print(max([len(x) for x in s.split() if x[0] != '0']))

Ответ:

**Присоединяйтесь и готовьтесь с нами: t.me/informatika_kege_itpy**

Untitled

Автор статьи: @ilandroxxy