Untitled

Условие: Тип 16 № 5874

Алгоритм вычисления значения функции F(n), где n  — натуральное число, задан следующими соотношениями:

F(n) = n + 3 при n ≤ 2;

F(n) = F(n − 1) + F(n − 2) при n > 2.

Чему равно значение функции F(7)? В ответе запишите только натуральное число.

Вариант 1: решение через рекурсивную функцию

Вариант 1: решение через рекурсивную функцию

Комментарии к первому варианту решения задачи:

  1. создаем функцию, которая будет принимать и обрабатывать значение функции
  2. если наше n ≤ 2
  3. то возвращаем n+3
  4. если наше n > 2
  5. то возвращаем F(n - 1) + F(n - 2) # то есть используем рекурсию
  6. вызываем функцию передавая ей в качестве аргумента n = 7
# Код решения Вариант 1
def F(n):
    if n <= 2:
        return n + 3
    if n > 2:
        return F(n - 1) + F(n - 2)
print(F(7))

Ответ: