№ 5627 (Уровень: Средний)

Разбор  9.PNG

(М. Ишимов) Откройте файл электронной таблицы, содержащей в каждой строке шесть натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнено хотя бы одно из условий:

–   в строке есть хотя бы одно повторяющееся число;

–   будучи упорядоченными, все числа строки образуют арифметическую прогрессию.

В ответе запишите только число.

Файлы к заданию: 9.xlsx

ray-so-export (7).png

  1. count = 0 - объявляем переменную count и присваиваем ей значение 0.
  2. for s in open('9.txt'): - начинаем цикл, перебирая строки s из файла '9.txt'.
  3. M = sorted([int(i) for i in s.split()]) - разделяем строку s на отдельные элементы, преобразуем их в целые числа и сортируем их в порядке возрастания, сохраняя результат в переменную M.
  4. **if len(set(M)) != len(M) or all(M[i + 1] - M[i] == M[1] - M[0] for i in range(len(M)** **- 1)):** - проверяем, если количество уникальных элементов в M не равно общему количеству элементов в M или если все разности между соседними элементами M равны разности первых двух элементов M.
  5. count += 1 - увеличиваем значение count на 1.
  6. print(count) - выводим значение count.
count = 0
for s in open('9.txt'):
    M = sorted([int(i) for i in s.split()])
    if len(set(M)) != len(M) or all(M[i + 1] - M[i] == M[1] - M[0] for i in range(len(M) - 1)):
        count += 1  
print(count)

Ответ: