Разбор 8.PNG

№ 5626 (Уровень: Базовый)

(М. Ишимов) Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, запись которых не начинается с нечётных цифр, не оканчивается цифрами 2 или 6, а также не содержит более двух цифр 7.

Untitled

Комментарии к коду решения:

  1. import itertools - Импортируем модуль itertools для работы с итераторами.
  2. count = 0 - Инициализируем счетчик для счета подходящих чисел.
  3. for s in itertools.product('01234567', repeat=5): - Генерация всех возможных комбинаций длины 5 из цифр 0-7 (восьмеричная система счисления) .
  4. slovo = ''.join(s) - Преобразуем кортеж s в строку slovo.
  5. if slovo[0] != '0': - Проверка: если первая цифра не равна '0'.
  6. if slovo[0] not in '1357': - Проверка: если первая цифра не содержится в '1357'.
  7. if slovo[-1] not in '26': - Проверка: если последняя цифра не содержится в '26'.
  8. if slovo.count('7') <= 2: - Проверка: если количество цифр '7' в слове не превышает 2.
  9. count += 1 - При выполнении всех условие, увеличивает счетчик на +1.
  10. print(count) - Выводим результат подсчета подходящих чисел.
import itertools
count = 0
for s in itertools.product('01234567', repeat=5):
    slovo = ''.join(s)
    if slovo[0] != '0':
        if slovo[0] not in '1357':
            if slovo[-1] not in '26':
                if slovo.count('7') <= 2:
                    count += 1
print(count)

Ответ:

**Присоединяйтесь и готовьтесь с нами: t.me/informatika_kege_itpy**

Untitled

Автор статьи: @ilandroxxy