Untitled

Условие: Тип 24 № 47228

Текстовый файл состоит из символов A, C, D, F и O.

Определите максимальное количество идущих подряд пар символов вида

$$ согласная + гласная.

$$

Для выполнения этого задания следует написать программу. Ссылка на файл, который необходимо обработать с помощью данного алгоритма.

Вариант 1: решение через цикл while

Вариант 1: решение через цикл while

Комментарии к первому варианту решения задачи:

  1. Открываем файл '24.txt' в режиме чтения и сохраняем его в переменную f
  2. Читаем первую строку из файла и сохраняем ее в переменную s
  3. Инициализируем переменные count и Max_count значением 0, а также переменную n значением 0
  4. Запускаем цикл while, который будет продолжаться, пока значение переменной n меньше длины строки s
  5. Проверяем, является ли текущий символ 'C', 'D' или 'F', а следующий символ 'A' или 'O’
  6. Если это так, увеличиваем значение переменной count на 1 и увеличиваем значение переменной n на 2
  7. Проверяем, больше ли текущее значение переменной count, чем значение переменной Max_count, и если это так, обновляем значение переменной Max_count
  8. Если условие не выполнено, сбрасываем значение переменной count на 0 и увеличиваем значение переменной n на 1
  9. Выводим значение переменной Max_count на экран
# Код решения Вариант 1
f = open('24.txt')
s = f.readline()
count = 0
Max_count = 0
n = 0
while n < len(s):
    if (s[n] == 'C' or s[n] == 'D' or s[n] == 'F') and (s[n+1] == 'A' or s[n+1] == 'O'):
        count += 1
        n += 2
        if Max_count < count:
            Max_count = count
    else:
        count = 0
        n += 1
print(Max_count)